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Trademarks 

Microsoft®, Windows®, Windows NT® and Windows VistaTM are registered trademarks or 
trademarks of Microsoft Corporation in the United States and/or other countries. 

 

Abbreviations 

Throughout this document the following abbreviations are used in text. 

� Microsoft® Windows VistaTM is abbreviated as “Windows  Vista”   

� Microsoft® Windows® XP is abbreviated as “Windows  XP”   

� Microsoft® Windows®2000 is abbreviated as “Windows  2000” 

� Microsoft® Windows® Millennium Edition is abbreviated as “Windows  Me” 

� Microsoft® Windows NT® Workstation 4.0 is abbreviated as “Windows  NT ” 

� Microsoft® Windows® 98 is abbreviated as “Windows  98” 
 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

  



 

CANON FINETECH SOFTWARE LICENSE AGREEMENT 
 

Note: Please read the following software license agreement (to be referred to as the "Agreement") carefully.  This Agreement is 
made between Canon Finetech Inc. (to be referred to as "Canon Finetech") and the user for use of software (to be referred to as the 
"Software," and to include manuals, printed matter and so forth in addition to this Agreement) provided with this Agreement by the 
ser for the purpose of using the applicable printer made by Canon Finetech (to be referred to as the "Printer").   u

 
The user shall be presumed to have agreed to this Agreement either by taking an action that indicates "Consent" to the terms of the 
Agreement or by using the Software.  The user shall not be permitted to use the Software in the case of not agreeing with the 
Agreement.   
 
1. License 
(1) Canon Finetech shall grant the user non-exclusive license to install the Software into a single computer and use such installed 
Software on such single computer at a time for the purpose of using the Printer.  The user may not use the Software on plural 
computers at a time or on a network.   
(2) The user shall be permitted to make one reproduction of the Software as a backup for using the Software on the basis of clause 
(1) above.   
(3) With the exception of that stipulated in clauses (1) and (2) above, any and all of intellectual property rights of Canon Finetech or 
licensors of Canon Finetech, whether express or implied, shall not be transferred or licensed to the user by this Agreement.   
 
2. Restrictions on Use 
(1) The user shall not allow the Software to be used by a third party by sub-licensing, transfer, sales, distribution, lease, loan or any 
other method.   
(2) The user shall not be permitted to revise, modify, decompile, disassemble or perform any other form of reverse engineering on all 
or any portion of the Software.  The user shall also not allow such actions to be taken by a third party.   
 
3. Title 
Title and ownership relating to the Software shall be retained by Canon Finetech or a licensor of Canon Finetech depending on their 
contents.   
 
4. Copyright Markings 
The user shall not alter, remove or delete any copyright markings of Canon Finetech or a licensor of Canon Finetech contained in the 
Software.   
 
5. Disclaimer and Exemption of Warranties 
(1) The Software is licensed "as is".  Canon Finetech, Canon Inc. that is parent company of Canon Finetech (to be referred to as the 
“Canon”), affiliates of Canon (exclude Canon Finetech, to be referred to as “Affiliates”) and their agents or vendors shall not make 
any warranty, whether express or implied, including warranty of product feasibility or suitably to a specific purpose, with respect to 
the Software. 
(2) Canon Finetech, Canon, Affiliates and their agents or vendors shall not be liable, as recognized by applicable laws, for any 
damages incurred due to the use or inability to use the Software (referring to all damages, including, but not limited to, lost profit 
and other derivative or incidental damages).  This shall apply similarly even if Canon Finetech, Canon, Affiliates and their agents or 
vendors were informed of the possibility of said damages.   
(3) Canon Finetech, Canon, Affiliates and their agents or vendors shall not bear any liability regarding any and all disputes arising 
between the user and a third party caused by or related to use of the Software. 
 
6. Export 
The user shall not export, either directly or indirectly, all or any portion of the Software without obtaining the required approval from 
the Japanese government or related foreign governments.   
 
7. Term of Agreement 
(1) This Agreement shall come into effect at the time the user has taken an action that indicates "Consent" to the terms of the 
Agreement or at the time the Software has been used, and shall remain in effect until terminated in accordance with clause (2) or (3) 
below.   
(2) The user shall be able to terminate this Agreement by discarding and erasing the Software and all of its reproductions. 
(3) This Agreement shall terminate immediately when the user has violated any of the terms of the Agreement. 
(4) If the Agreement has been terminated as result of clause (3) above, the user shall promptly discard or erase the Software and all 
of its reproductions.   
 
8. U.S. Government Restricted Rights Notice 
The Software is a "commercial item," as that term is defined at 48 C.F.R. 2.101 (Oct. 1995), consisting of "commercial computer 
software" and "commercial computer software documentation," as such items are used in 48 C.F.R. 12.212 (Sept. 1995).  Consistent 
with 48 C.F.R. 12.212 and 48 C.F.R. 227.7202-1 through 227.7202-4 (June 1995), all U.S. Government End Users shall acquire the 
Software with only those rights set forth herein.  The manufacturer is Canon Finetech Inc., 5540-11 Sakatemachi, Joso-shi, Ibaraki 
303-8503, Japan.  The term "the Software" used in this clause refers to and indicates the "Software" defined in this Agreement.   
 
9. Separable Agreement 
In the case it has been determined that a portion of any of the terms of this Agreement become invalid by law, the other terms of the 
Agreement shall remain completely in effect.   
 
Canon Finetech Inc. 
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Introduction 
 

Introduction 

This manual contains descriptions of operating instructions for the Application software “M-1 Pro 
II PC”. 
Please read this manual carefully to ensure correct operation. 
 
This manual has been written with the assumption that users have knowledge of basic Windows 
operations and functions. We recommend that users familiarize themselves with the Windows 
environment before using M-1 Pro II PC. For details about Windows terminology or operations 
such as ‘Open’, refer to the documentation provided with Windows. 
 
 

Conventions Used in This Manual 
 
The following notational conventions are used in this manual: 
 

Convention Meaning 
[XXX (A)] – [YYY (B)] Select YYY from the XXX menu.  

You can also perform the same command on the keyboard by 
pressing the A key and then the B key while holding down the 
Alt key. 

[X] 
[X] + [Y] 

Press the X key on the keyboard.  
On the keyboard, press the Y key while holding down the X 
key.  

“XXXXX” Messages displayed on the screen are enclosed in “ ”. 
[XXX] button Buttons displayed on the screen are enclosed in [ ]. 
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System Requirements 

System Requirements 

The hardware and software items listed below are required for using M-1 Pro II PC. 
 

� Compatible operating systems 
 
Windows 98 (English) 
Windows Me (English) 
Windows NT (English) 
Windows 2000 (English) 
Windows XP (English) 
Windows Vista (English) 
 
� If you are using Windows Vista/XP/2000/NT, be sure to log on as a member of Administrators 

when starting up. 
 

� Computer 
 
A computer that supports any of the above operating systems. 
 

� Monitor and video driver 
 
A Monitor capable of 800 x 600 dots resolution and 256 color display or higher. 
1024 x 768 recommended. 
 
� When using an 800 x 600 dot monitor, set the display font size to “Small Fonts”. 
 

� Memory 
 
At least the recommended amount of memory for the operating system. 
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Installing 

Installing 

Installing M-1 Pro II PC and the Printer Driver 
 
 
Install M-1 Pro II PC and the printer driver for the M-1 Pro II into your computer.  
This section describes how to install M-1 Pro II PC and the printer driver using Windows 2000 
as an example. 
 
 
� Close all applications before installing the software.  
� If you are using Windows Vista/XP/2000/NT, be sure to log on as a member of Administrators 

when starting up. 
� Windows Vista/ XP allows multiple users to use one computer at the same time. However, 

only one user can log on to the computer when making settings. 
 
 
 
 
1. Have ready the installation CD-ROM that contains the software. 
 
2. Turn on your computer and start Windows. 
 
3. Insert the CD-ROM to install the software into your CD-ROM drive. 
� If the CD-ROM does not start automatically, double-click on the CD-ROM drive icon. 

 
4. Install the Application Software. 
 

• Windows XP/2000/NT/Me/98 
The Installation menu appears.  
Click the [Install the Application Soft] button. 
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Installing 

 
• Windows Vista 

When the “AutoPlay” screen appears, click [Run LaunchM1.exe]. 

 
 

When the “User Account Control” dialog box appears, click the [Continue] button. 

 
 
 
 

(1) Click the [Next] button. 
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Installing 

 
 

(2) The “Software License Agreement” screen appears. 
 

• Windows XP/2000/NT/Me/98 
Read the Software License Agreement, click the [Yes] button. 

 
 

• Windows Vista 
Read the Software License Agreement, select “I accept the terms of the license 
agreement” and then click the [Next] button. 

 
 
 

(3) Specify the destination for installation and then click the [Next] button. 
 

• To install the software in the folder displayed in “Destination Folder”, click  
the [Next] button. 
• To install the software in a different folder, click the [Browse] button and  
specify a folder.  
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Installing 

 
 

(4) Follow the instructions on the screen to complete the installation. 
 

• Windows XP/2000/NT/Me/98  
The “Select Program Folder” screen appears.  
Click the [Next] button. 

 
 

• Windows Vista 
The “Ready to Install the Program” screen appears.  
Click the [Install] button. 

 
 
 
(5) Click the [Finish] button. 

  
 

This completes the Application Software installation. 
Next, Install the Printer Driver. 
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Installing 

 
5.  Install the Printer Driver. 
 

• Windows XP/2000/NT/Me/98 
Click the  [Install the Printer Driver] button of the installation menu. 

 
 

Click the       button.  
 

 
 
 
 
 
 
 
 

 
The “Printers” folder opens. Double-click the [Add Printer] icon. 

 
 
 
 
 
 
 
 
 
 
 
 

 
The “Add Printer Wizard” starts. Click the [Next] button. 

 
 

7 



Installing 

 
• Windows Vista 

The “Printers” folder opens. Click the [Add a printer] button.  

 
 
 
 

(1) Select “Local printer” and then click the [Next] button. 

 
 
 

(2) Select the port that you want to use and then click the [Next] button. 
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Installing 

 
 

(3) Click the [Have Disk…] button. 

 
 
 

(4) Click the [Browse…] button. 

 
 
Select [DRV] folder – [2KXP] folder – [Pro II2ke.inf] file on the CD-ROM, and then click 
the [Open] button. 

 
 
� The folders you select differ according to the operating system you are using. 

• With Windows 98 or Windows Me, select the [9XME] folder – [ProII9xe.inf] file. 
• With Windows 2000 or Windows XP, select the [2KXP] – [ProII2ke.inf] file. 
• With Windows NT, select the [NT40] folder– [ProIINTe.inf] file. 
• With Windows Vista, select the [VISTA] folder – [ProIIvte.inf] file. 
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Installing 

 
 

(5) Click the [OK] button. 

 
 
 

(6) Select “M-1 Pro II” as the printer, and then click the [Next] button.  

 
 

� The following screen only appears if a printer driver is already installed in the system. 
• Windows XP/2000/NT/Me/98 

Select “Replace existing driver” and then click [Next] button. 

 
• Windows Vista 

Select “Replace the current driver” and then click [Next] button. 
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Installing 

 
 

(7) Click the [Next] button. 

 
 
� Never change the printer name. Should you change it, print data is not properly sent to 

the printer and prints fail. 
 

 
(8) Follow the instructions on the screen to complete the installation. 
 

Select “Do not share this printer” in the “Printer Sharing” screen, and then click [Next] 
button. 

 
 
Select “No” in the “Print Test Page” screen, and then click [Next] button. 
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Installing 

 
(9) Click the [Finish] button. 

 
 

� If you are using Windows 2000 and the message “Digital Signature Not Found” appears, 
click the [Yes] button. (The printer driver will not be installed if you click the [No] button.) 

 
 
 
 
 
 
 
 
 
 

 
 

� When the following screen appears with Windows XP, click the [Continue Anyway] 
button. (The printer driver will not be installed if you click the [Stop Installation] button.) 

 

 
 
 
 
 
 
 
 
 

 
 

� When the following screen appears with Windows Vista, click the [Continue] button and 
select “Install this driver software anyway”. (The printer driver will not be installed if you 
click the [Cancel] button and select “Don’t install this driver software”.) 
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Installing 

 
 

(10) The M-1 ProⅡ icon is added to the “Printers” folder. 

 
 

This completes the Printer Driver installation. 
 
 
6. Restart your computer. 
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Installing 

 
 

Installing the Printer Driver at a Later Time 
 
Follow the procedure below to install the driver for the M-1 Pro II at a later time. Restart your 
computer after installing the printer driver. 
 
• Windows 2000/NT/Me/98 

Click the [Start] button, and select [Settings] – [Printers]. Next, double-click the [Add Printer] icon to 
start the “Add Printer Wizard” and install the printer driver.  

 
• Windows XP 

Click the [Start] button, and select [Control Panel] – [Printers and Other Hardware] – [Add a printer], to 
start the “Add Printer Wizard” and install the printer driver.  
 

• Windows Vista 
Click the [Start] button, and select [Control Panel] – [Hardware and Sound] – [Printers]. Next, click the 
[Add a printer] button and install the printer driver. 

 

Uninstalling the Software 
 
• Windows 2000/NT/Me/98 

Click the [Start] button, select [Settings] – [Control Panel], and then double click the [Add/Remove 
Programs] icon. Next, select [M-1 Pro II PC] from the list, and then click the [Add/Remove] button. 
When the confirmation message appears, click the [Yes] button. 

 
• Windows XP 

Click the [Start] button, and then select [Control Panel] – [Add or Remove Programs]. Next, select  
[M-1 Pro II PC] from the [Currently installed programs] list, and then click the [Change/Remove] 
button. When the confirmation message appears, click the [OK] button. 

 
•   Windows Vista  

Click the [Start] button, select [Control Panel] – [Programs], and then click [Uninstall a program]. Next, 
select [M-1 Pro II PC] from a list of the programs, and then click the [Uninstall/Change] button. When 
the confirmation message appears, click the [OK] button. (When the “User Account Control” dialog 
box appears, click the [Continue] button.) 
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Starting M-1 Pro II PC 

Starting M-1 Pro II PC 

Starting 
You can start M-1 Pro II PC by one of the following methods: 
 
• Double-click the [M-1Pro II PC] icon on the desktop. 
• Click the [Start] button, and then select [All Programs] or [Programs] – [M-1Pro II PC] – [M-

1Pro II PC]. 
 
The main screen appears when you start M-1 Pro II PC. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
For details of the main screen parts, refer to “Screen Structure” below. 
 

Shutting Down 
You can shut down M-1 Pro II PC by one of the following methods: 
 
• Select [File (F)] – [Exit (X)]. 

• Click the e  upper right of the main screen. 
 
� If you are editing data when you shut down M-1 Pro II PC, a message asking whether to save 

the data appears.  
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Screen Structure 

Screen Structure 

This section describes details of the tool buttons and menus contained in M-1 Pro II PC.  
 

Main Screen 
This appears when you start M-1 Pro II PC. 

Data toolbar 

 

Menu bar 

Title bar 
Send toolbar 

Edit toolbar 

Data list

Status bar 

Style settings/Data display area 

f.g.1  Main screen 
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Screen Structure 

Toolbar 
 
The toolbar contains the following buttons. 
 

Tool button Description 

 

Creates a new data list.  
Does the same thing as selecting [New] from the [File] menu. 
� If you are editing data, a message asking whether to save the data 

appears. 

 

Opens an existing file or CSV file and loads the data. 
Does the same thing as selecting [Open] from the [File] menu. 
� If you are editing data, a message asking whether to save the data 

appears.  

 
Saves the data you are editing in an existing file. 
Does the same thing as selecting [Save] from the [File] menu. 

 
Sends the data you are editing to the M-1 Pro II. 
Does the same thing as selecting [Send] from the [File] menu. 

 
Sets a numbering and adds numbering data to the specified pages. 
Does the same thing as selecting [Numbering] from the [Edit] menu. 

 
Inserts a blank page in front of the cursor page. 
Does the same thing as selecting [Page Insert] from the [Edit] menu. 

 
Deletes the cursor page. 
Does the same thing as selecting [Page Delete] from the [Edit] menu. 

 
Cuts the specified page and pastes it to the clipboard. 
Does the same thing as selecting [Page Cut] from the [Edit] menu. 

 
Copies the contents of the specified page to the clipboard.  
Does the same thing as selecting [Page Copy] from the [Edit] menu. 

 

Pastes the contents of the clipboard by inserting it in front of the specified 
page. 
Does the same thing as selecting [Page Paste] from the [Edit] menu. 

 

Style Settings/Data Display Area 
 
This area displays current format settings. To change the format settings, click the [Setting] 
button. 
For details about settings, refer to “Format Settings” in “Basic Operations.” 
 

Data List 
 
This is a list of files currently being edited. 
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Screen Structure 

Menu Bar 
 
The Menu bar contains the following menus. 
 

 
 
 

� [File] menu 
 

 
 

Menu item Description 
New (N) Creates a new data list.  

There is also the  button that performs this function. 
� If you are editing data, a message asking whether to save the data 

appears. 
Open (O) Opens an existing file or CSV file and loads the data. 

There is also the  button that performs this function. 
� If you are editing data, a message asking whether to save the data 

appears.  
Add (L)  Opens another file and adds the data to the data you are editing. 
Save (S) Saves the data you are editing in an existing file. 

There is also the  button that performs this function. 
Save As (A) Saves the data you are editing in a new file with a name that you assign. 
Send (P) Sends the data you are editing to the M-1 Pro II. 

There is also the  button that performs this function. 
Exit (X) Shuts down M-1 Pro II PC. 
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Screen Structure 

� [Edit] menu 
 

 
 

Menu item Description 
Cut (T) Cuts the specified data and pastes it to the clipboard. 
Copy (C) Copies the selected contents to the clipboard.  
Paste (P) Pastes the contents of the clipboard. 
Delete (D) Deletes the selected part. 
Numbering (N) 
 

Sets a numbering and adds numbering data to the 
specified pages. 
There is also the  button that performs this function. 

Page Cut (K) 
 

Cuts the specified page and pastes it to the clipboard. 

There is also the  button that performs this 
function. 

Page Copy (O) 
 

Copies the contents of the specified page to the 
clipboard.  

There is also the  button that performs this 
function. 

Page Paste (L) 
 

Pastes the contents of the clipboard by inserting it in 
front of the specified page. 

There is also the  button that performs this 
function. 

Page Insert (I) 
 

Inserts a blank page in front of the cursor page. 

There is also the  button that performs this 
function. 

Page Delete (R)  
 

Deletes the cursor page. 

There is also the  button that performs this 
function. 

Page Setting (P) Changes the format settings for the cursor page. 
Format 
Setting (S) Default Setting (D) Sets the default format to be used when creating new 

data lists or inserting pages. 
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Screen Structure 

�  [View] menu 
 

 
 

Menu item Description 
Data Toolbar (1) Shows or hides the data toolbar. 
Send Toolbar (2) Shows or hides the send toolbar. 
Edit Toolbar (3) Shows or hides the edit toolbar 
Status Bar (S) Shows or hides the status bar. 

 
 

� [Remote] menu 
 

 
 

Menu item Description 
Start Print (P) Sends a print command to the M-1 Pro II. 
Save Data (S) Sends a save data command to the M-1 Pro II. 

 
 

� [Help] menu 
 

 
 

Menu item Description 
Help                   F1 Displays M-1 Pro II PC help. 
About M-1Pro II PC(A) Displays M-1 Pro II PC version information. 

 
 

Status Bar 
 
Displays the current status of the M-1 Pro II PC. 
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Operating M-1 Pro II PC 

Operating M-1 Pro II PC 

File Types 
With M-1 Pro II PC, you can load the following file types into the data list.  
 
• Original data files (.mtd) 
• CSV files (Comma separated text files) 

To load data into the data list, files must meet the following conditions:  
 

• 1st line:  First line of character data 
• 2nd line:  Second line of character data 
• 3rd line: Number of continued printing 

 
� Data from and including the 4th line is ignored. 

 
(E.g.1) Loading CSV data into M-1 Pro II PC 
 

(Data List) 
1st page 
2nd page 
3rd page 

 
A,    1 2 3 4,     1,    A,    5 6 7 8 · · · · 
B,    1 2 3 4,     2,    B,    5 6 7 8 · · · · 
C,    1 2 3 4,     3,    C,    5 6 7 8 · · · · 

Invalid data 

 
 
 
 
 
 
 ContinuousLines lst 2nd 
 

(Data List)  
 
 
(E.g.2) CSV data from e.g.1 loaded into the data list.  
 

Page 1st line 2nd line Continuous 
1 A 1 2 3 4 1 
2 B 1 2 3 4 2 
3 C 1 2 3 4 3 
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Operating M-1 Pro II PC 

Basic Operations 
This section describes the methods for creating new data lists, creating data lists from existing 
data and sending data to the M-1 Pro II. 
 

Creating a New Data List 
 
1. Click [New] in the [File] menu or click the  button. 

A new data list is created. 
The format set in [Format Setting] – [Default Setting] in the [Edit] menu is used. 

 
� If you are editing data, a message asking whether to save the data appears.  

 

[Yes]: Saves the data you are editing and creates a new data list. 
If the file already has a name, it is overwritten. 
If the file does not have a name, the [Save As] dialog box appears, where 
you can give the file a name. 

[No]: Creates a new data list without saving the data you are editing. 
[Cancel]: Cancels the [New] command. 
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Operating M-1 Pro II PC 

Opening Existing Files 
 
You can load your own original data files (.mtd) or CSV files into the data list.  
 
1. Click [Open] in the [File] menu or click the  button. 

The [Open] dialog box appears. 

 
 
2. Select an original data file (.mtd) or CSV file, and then click the [Open] button. 

The selected file is loaded and displayed in the data list. 
The format set in [Format Setting] – [Default Setting] in the [Edit] menu is used. 

 
� If you are editing data, a message asking whether to save the data appears.  

 

[Yes]: Saves the data you are editing and creates a new data list. 
If the file already has a name, it is overwritten. If the file does not have a 
name, the [Save As] dialog box appears, where you can give the file a 
name. 

[No]: Opens the selected file without saving the data you are editing. 
[Cancel]: Cancels file loading. 
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Operating M-1 Pro II PC 

3. When you select a CSV file, the [Format Setting] dialog box appears. 
For details about individual setting items, refer to “Format Settings”. 

 
� If you select [1 Line] in [Lines], the first line of data in the CSV file is loaded, but the 

second line is ignored. 
 

Loading Additional Data  
 
You can add data to a specified position in the data list.  
 
1. Select the file you want to add, and then click the [Open] button. 

The [Open] dialog box appears. 
 
2. Select the file you want to add, and then click the [Open] button. 

The data in the selected file is added at the cursor position. 
 

Saving Data Lists 
 

� Overwriting when saving 
 
1. Click [Save] in the [File] menu or click the  button. 

The file you are editing is overwritten. 
 
� If “Untitled” appears in the title bar, the [Save As] dialog box appears. For details about 

saving the file, refer to “Saving a file with a new name”. 
 

� Saving a file with a new name 
 
1. Select [Save As] from the [File] menu. 

The [Save As] dialog box appears. 
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Operating M-1 Pro II PC 

2. Input the file name, specify the file type, and then click the [Save] button. 
Select the file type from the following: The contents that are saved depend on the file type. 

 
[Original data files (.mtd)] Saves format settings and data list contents. 
[CSV file]: Saves the first and second lines of character data in the data 

list, and the numbering value. 

 
The data list is saved with the file name you assigned. 

 
� If a file already exists with the same name as the one you input, a message appears 

asking whether it is ok to overwrite the existing file.  

 

[Yes]: The file is overwritten. 
[No]: The file is not saved. 
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Operating M-1 Pro II PC 

Sending Data to the Printer 
 
You can send data you create with M-1 Pro II PC to the M-1 Pro II. 
This section also describes settings for saving and printing sent data. 
 
1. Click [Send] in the [File] menu or click the  button. 

The [Data Transfer] dialog box appears. 
 
2. Set each of the items. 

 

[Transfer Mode]  
[Overwrite internal memory.]: Clears the document area in the printer, and saves 

the transmitted data at the beginning of the 
document area. 

[Add to internal memory.]: Adds the sent data at the end of the last page in the 
printer.  
(The printer adds new pages to the data in the 
printer.) 

[File Save]  
[Save transmitted data.]: When this option is selected, after list data is sent to 

the printer, data in the printer’s document area is 
saved under the specified file name(s) in the 
specified folder(s) of the printer's storage area. 
If you do not select this the data will not be saved. 

[File name]: Inputs the file name. 
[Folder No.]: Selects the folder number (from 1-3) for saving data. 
[Print]  
[Print data in memory.]: Select this to print data stored in the printer’s 

memory after sending, according to settings you 
specify. 
If you do not select this the data will not be printed. 
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Operating M-1 Pro II PC 

[Print Media]: Selects the type of printing media. 
Select either Tube, Shrink Tube, Label,  
4mm I.D. Strip, Clear Tube, Wrap Around or 
Terminal I.D. 

[Media Size]: Selects the size of printing media. 
The sizes you can select depend on the type of 
printing media used. 
Tube : 2.5, 3.0, 4.0, 5.0, 6.0 or 6.5mm 
Shrink Tube : 3.0, 3.2, 4.8, 6.0 or 6.4mm 
Label : 6.0, 9.0, 12.0mm 
4mm I.D. Strip : Size not selectable. 
Clear Tube : 2.5, 3.0, 4.0, 5.0, 6.0 or 6.5mm 
Wrap Around : Size not selectable. 
Terminal I.D.  : 8.0, 8.5, 9.0, 9.5 or 10.0mm 

[Sets to Print]: Selects the number of items to be printed. 
Select from 1-10. 

 
3. Click the [OK] button. 

Format settings and data list contents are sent to the printer. 
 

• If there is no data when you click the [OK] button, “No character data” appears. 
• Click the [Cancel] button to cancel data transfer and close the dialog box. 
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Creating Numbering 
This section describes how to incorporate numbering into the current page in the data list, 
create pages for printing according to these values and add the pages to a data list. 
 
� This function for creating numbering is the same as the function in the M-1 Pro II. 
 
1. Click [Numbering] in the [Edit] menu or click the  button. 

The [Numbering] dialog box appears. 
 
2. Set each of the items. 

 

[Mode]: Selects the mode of numbering. 
Select from Decimal, Hexadecimal, A to Z or a to z. 
The numbering range you can select depends on the numbering 
mode. 
Decimal: 0 - 99 (0 - 9 for single digit) 
Hexadecimal: 0-FF (0 - F for single digit) 
A to Z: A to Z 
a to z: a to z 

[Start value],  
[End value]: 

Selects the start and end values for the numbering. 
Select from Decimal, Hexadecimal, A to Z or a to z. 
� If the start value is higher than the end value, the numbering 

will be in descending order. 
[Padding Character]: Selects digit matching method. 

Select from None, Zero, or Space. 
 
� The character string length is checked when creating a numbering. When it is no longer 

possible to input characters, “Length exceeded. Input data exceeds set length.” appears. 
 
3. Click the [OK] button. 

A numbering is created in the data list using the numbering information from the cursor 
page. 

 
• Click the [Cancel] button to quit numbering creation and close the dialog box. 

 
� To delete a numbering, select the page in the data list, and then select [Delete] from the [Edit] 

menu. 
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Format Settings 
This section describes format setting items and settings procedures. 
You can set formats for individual pages, and there is also a default format used when creating 
or inserting new pages. 
There procedure for setting a format for an individual page is described here. The procedure for 
setting the default format is the same. 
 
� If you try to change the different page format by selecting more than one page in the data list, 

the settings will revert to the unset state (become blank settings).  
 
1. In the data list, select the page whose format you want to change, and then select [Format 

Setting] – [Page Setting] from the [Edit] menu. 
To change the default format, select [Format Setting] – [Default Setting] from the [Edit] 
menu. 
The [Format Setting] or [Default Setting] dialog box appears. 

 
2. Set each of the items. 

 

[Orientation]: Selects the orientation for printing. 
Select from Hor/Hor char, Vert/Vert char or Vert/Hor char. 
The default at installation is [Hor/Hor char]. 
[Vert/Hor char] print is only available when there are no characters 
input. 

[Frame]: Selects the type of frame to surround the characters. 

Select from None, , , ,  

 or . 
The default at installation is [None]. 

[Set Length]: Selects the length of tube to be cut. 
With [Specify] selected, you can specify a length from 8-150mm. 
Select this to calculate the character string length from the 
character size, character space, frame and lines and fit the 
character string within the cut length. 
The default at installation is [Automatic]. 
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[Alignment]: Selects way in which characters are aligned. 
Select either Centered, Left 2mm, Left 3mm, Left 4mm or Left 5mm. 
You cannot select [Centered] when [Automatic] is selected for [Set 
Length]. 
The default at installation is [Centered]. 

[Character Size]: Selects the size of the characters. 
Select either 2mm Half, 2mm Norm, 3mm Half, 3mm Norm, 6mm 
Half or 6mm Norm.  
The default at installation is [3mm Norm]. 

[Character Space]: Selects the space between characters. 
Select from Narrow, Medium, or Wide. 
The default at installation is [Narrow]. 

[Lines]: Selects the number of lines. 
Select either 1 Line or 2 Lines. 
When [Character Size] is set to [6mm Half] or [6mm Norm], the 
number of lines is automatically set to 1 line. (You cannot change 
the number of lines.) 
The default at installation is [1 Line]. 

[Continuous]: Selects the number of items to be printed. 
Select from 1-100. 

 
3. Click the [OK] button. 

The set length check takes place. 
 

• If there is a page to which the specified settings cannot be applied, a message asking 
whether to apply the changes only to those pages that can be changed.  

• If the settings cannot be applied to any pages, “Cannot modify.” appears.  
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Remote Operation 
Without using the print controls or file functions on the printer, you can operate the printer from 
M-1 Pro II PC, specify printing media and print, and save data in the printer’s document area. 
 

Starting Printing 
 
1. Select [Start Print] from the [Remote] menu. 

The [Print] dialog box appears. 
 
2. Set each of the items. 
 
� While M-1 Pro II PC is running, the previous settings used are displayed as default 

settings. 

 
 

[Print Media]: Selects the type of printing media. 
Select either Tube, Shrink Tube, Label, 4mm I.D. Strip, Clear Tube, 
Wrap Around or Terminal I.D. 

[Media Size]: Selects the size of printing media. 
The sizes you can select depend on the type of printing media used. 
Tube :2.5, 3.0, 4.0, 5.0, 6.0 or 6.5mm 
Shrink Tube :3.0, 3.2, 4.8, 6.0 or 6.4mm 
Label :6.0, 9.0, 12.0mm 
4mm I.D.Strip :Size not selectable. 
Clear Tube :2.5, 3.0, 4.0, 5.0, 6.0 or 6.5mm 
Wrap Around :Size not selectable. 
Terminal I.D. : 8.0, 8.5, 9.0, 9.5 or 10.0mm 

[Sets to Print]: Selects the number of items to be printed. 
Select from 1-10. 

 
3. Click the [OK] button. 

The data is sent to the printer. 
 

• Click the [Cancel] button to cancel printing and return to the main screen. 

31 



Operating M-1 Pro II PC 

Saving Print Data 
 
1. Select [Save print data] from the [Remote] menu. 

The [Save print data] dialog box appears. 
 
2. Set each of the items. 

 

[File name]: Inputs the file name. 
[Folder No.]: Selects the folder number (from 1-3) for saving data. 

 
3. Click the [OK] button. 

The file name you specified, folder number and save command are sent to the printer. 
 

• Click the [Cancel] button to cancel data saving and return to the data input screen. 
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